zen.org Communal Weblog

June 3, 2004

I²C Woes

Filed under: — Sven @ 19:08 GMT

My I²C woes continued today. I have twelve SUPER X5DPA-GG systems with HighPoint RocketRAID 1820s. HighPoint provides an “OpenBuild”, currently v1.02, but this doesn’t build on Linux kernels above 2.6.3. I need I²C working because these machines are in a room with a history of AC problems. The SMBus devices on the SUPER X5DPA-GG don’t work with the I²C drivers from the 2.6.3 kernel, but with the 2.6.6 kernel do.

After I submitted a support request to HighPoint, I set of finding my own solution. I got lucky. I simply replaced the I2C directory in the 2.6.3 kernel source tree with the one from the 2.6.6 kernel. Reconfigure and rebuilt the kernel, and it works like a charm!

I hope HighPoint gets back with a new driver. Hopefully this time they will open source it and not just “OpenBuild” it. Whatever “OpenBuild” means. I might of tried to fix it myself if it was open source.

Big amount of citizens may not get health insurance so they have choice to pay for the really expensive prescription meds or research how to buy generic medications online. Generic drugs are as safe as other branded meds. Only reputable pharmacy produces them such as German Remedies. Having this in head one can buy orlistat uk in generic online drugstore including free shipping anywhere in the world

Powered by WordPress